Toyota GR86 Forum - GT86 Forum, Subaru BRZ Forum, Scion ... banner

Are you having issues with Starlink???

  • Major Issues (Camera, BT, Audio, etc...)

    Votes: 1 6.7%
  • Minor Issues (Random Issues)

    Votes: 7 46.7%
  • No Issues

    Votes: 7 46.7%
1 - 20 of 23 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
2022 BRZ Limited 6MT (1.5 months + 4,000 miles as of September 20th)

Subaru Starlink Head Unit began having issues about a week ago. For all of these problems it doesn't matter if I am parked, driving, engine on, engine off, accessory mode, parking brake on, parking brake off, doors closed, doors opened, doors locked, doors unlocked... I have not been able to get any of these options to come back on.

#1 (minor): An ongoing issue with CarPlay randomly dropping off the entire USB Connection. This happens from time to time, and while it is annoying (especially in a phone call) it isn't the biggest problem I'm seeing...

#2 (minor): "Car Settings" and "Meter Screen" options became greyed out. When I go to the Car menu under settings I only see the "Units" options as opposed to all the settings. This started about 2 weeks ago.

#3 (minor): "Audio Info" not showing on dash display. This happened a little while after I lost the "Car Settings", but I'm not sure at what point this became a problem.

#4 (major): REAR CAMERA not available... It is not coming on in any situation. I even looked up how to go into "FACTORY MODE" on the Head Unit (Factory Mode: hold "forward" and "back" button on HU and double tap the "Volume" knob. then release all buttons) and it does not show a camera connected at all.

This last one happened this morning (2022 September 20) after I tried to do a Software Update via WiFi using my mobile hotspot.

Any ideas on how to fix these? I prefer to fix it myself if I can since this is my daily driver.

(also added a poll so we can see if this is common at all)

Gadget Communication Device Font Display device Electronic device


Vehicle audio Personal luxury car Center console Audio equipment Technology
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #6 ·

·
Registered
GR86 MT Pavement
Joined
·
1,035 Posts
Mine got slightly better after unpairing and re pairing my phone. Still happens. (AA)

Haven't had any of the other issues mentioned by the OP, just the disconnect for AA with a clock error. I did set the clock (was already set).

I might try a factory reset if it continues after a dealer visit.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #14 ·
I wonder if there is a short somewhere or a loose connection along the wiring?
Normally this would be the first place I would look, but since the camera functionality became unresponsive after I tried a software update on the head unit while the vehicle was parked - I feel like the software itself is the problem.
 

·
Registered
2022 GR86 6AT Base Steel
Joined
·
387 Posts
I am sure you already tried this, but there is an option to factory reset the headunit. Try that if you haven’t.

My version is the same since I got the car early January. I disabled auto updates because that is a disaster waiting to happen, but manually check every couple months in a controlled fashion. No new version for me.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #16 ·
I am sure you already tried this, but there is an option to factory reset the headunit. Try that if you haven’t.

My version is the same since I got the car early January. I disabled auto updates because that is a disaster waiting to happen, but manually check every couple months in a controlled fashion. No new version for me.
You are correct - I have tried that, and this is when it gets weird: When I try to do that - nothing happens. :oops: I can go to that option, touch the screen, it highlights, and when I finish tapping the screen... it does nothing. This also leads me to thinking the software has an issue.
 

·
Registered
2022 GR86 6AT Base Steel
Joined
·
387 Posts
I don‘t suspect a physical connection issue. It definitely sounds like software. I have a howto for a spare tire subwoofer install in howto subforum that has a video that shows how to remove the head unit. If you take it out, be very careful not to scratch anything. Use lots of towels. I will say the wires on the back of the headunit can get wedged up in the car frame. But if it was working when you got it, I highly doubt a connection issue. The connectors are super tight.
 
1 - 20 of 23 Posts
Top